其他技術問題及疑難排解

其他技術問題及疑難排解

  • 問1.
    為什麼某些「香港政府一站通」網上服務不接受我在微軟視窗輸入的某些漢字?

    這是因為自微軟視窗 Vista 起採用了新的編碼標準 ISO/IEC10646:2003 和《香港增補字符集-2004》。這些新標準與「香港政府一站通」網上服務現時採用的最低標準 ISO/IEC 10646-1:2000 和《香港增補字符集-2001》不同。以「」字為例,經微軟視窗(Vista 或之後)輸入的編碼是 20779,並不相容於 ISO/IEC10646-1:2000 和《香港增補字符集-2001》。

  • 問2.
    「香港政府一站通」網上服務為何不採用微軟視窗所採用的最新的標準?

    在採用一套新標準前,香港特區政府必須了解市場對新標準的採納情況和確保香港的電腦用戶普遍都能接受以新標準編碼的資訊。由於新標準所採納的字數較現用標準有較大的增長,舊電腦用戶或須要更新某些軟件甚至硬件才能使用新標準。這過程可能需要一段時間。

  • 問3.
    除了微軟視窗外,還有哪些操作系統有類似的文字處理兼容問題?

    Mac OS X 和 Linux(例如 Mac OS X 10.4, Red Hat Linux 5, Fedora 7)都有類似的問題。

  • 問4.
    為什麼電腦要按照標準來處理文字?「香港政府一站通」網上服務所採用的又是什麼標準?

    一般人辨認文字是靠字形的,但電腦辨認文字是靠編碼。例如 0041 代表「A」,7532 代表「甲」。若要減少在進行電子通訊時資料失誤的情況,相關電腦必須按照特定標準來處理文字。這些標準一方面規範電腦須要處理哪些文字,另一方面規範這些文字的編碼。現時「香港政府一站通」網上服務所採用的最低標準是 ISO/IEC 10646-1:2000 及《香港增補字符集-2001》。

  • 問5.
    為什麼處理文字的標準會有不同的版本?

    早年利用電腦處理漢字時,國際標準化組織(The International Organization for Standardization,簡稱 ISO)把常用的漢字納入了一套名為 ISO/IEC 10646 的國際編碼標準。隨後,為了不同人士的需要,ISO 陸續加入其他字並更新該標準。已發表的版本有 ISO/IEC 10646-1:1993、ISO/IEC 10646-1:2000 和 ISO/IEC 10646:2003 等等。如需要更多關於該標準的資料,請瀏覽以下網址:

  • 問6.
    既然有 ISO/IEC 10646 國際編碼標準,為何還需要《香港增補字符集》?

    《香港增補字符集》包含了香港特區政府及市民在中文電子通訊中有需要使用及在本地通行的一些漢字,例如「深水埗」的「埗」字,「鰂魚涌」的「鰂」字。《香港增補字符集》亦有不同的版本。如需要更多有關於《香港增補字符集》的資料,請瀏覽以下網址:

  • 問7.
    使用「香港政府一站通」網上服務時,需要安裝《香港增補字符集》嗎?

    若你需要輸入特別的中文字符,才需安裝《香港增補字符集》。在微軟視窗 Vista 或之後版本,已內置《香港增補字符集》支援。

  • 問8.
    使用「香港政府一站通」網上服務時,需要注意什麼?

    使用「香港政府一站通」網上服務時,需要注意以下事項:

    • 切勿同時以多個視窗進入同一網上服務,因為這會影響正常的服務系統流程。
    • 如欲終止你正在使用的網上服務,你應點擊由該服務提供的按鈕以離開有關網上服務,否則「香港政府一站通」伺服器會根據最後收到的指令,繼續處理交易。
  • 問9.
    使用「香港政府一站通」網上服務時,如何尋求協助?

    若使用「香港政府一站通」網上服務時出現問題,你可參考列於網頁左欄的提示,以電話或電郵聯絡有關服務的支援熱線。

  • 問10.
    為何我不可以透過某些操作系統和瀏覽器組合來使用部分「香港政府一站通」網上服務?

    大部分操作系統上使用的瀏覽器均能用於瀏覽「香港政府一站通」的網頁。這些操作系統包括微軟視窗,Linux 和 Mac OS X。因此在一般情況下用家可以順利地瀏覽「香港政府一站通」。

    「香港政府一站通」有部分網上服務需要使用數碼證書。為確保認證程序的高度安全性,這些網上服務必須就個別版本的操作系統和瀏覽器進行測試和作出調校。由於測試網上服務需要大量資源,要在所有操作系統和瀏覽器組合上測試所有網上服務並不可行。因此我們採取了一個務實的方法,優先測試最流行的操作系統和瀏覽器組合。這些組合已列載於使用「香港政府一站通」網上服務的系統需求。除了以上所列的操作系統及瀏覽器組合外,你亦可以使用其他瀏覽器進入大部分不須用戶身分核證的網上服務。

    此外,個別「香港政府一站通」網上服務或需要特定的操作系統和瀏覽器,以確保服務正常及暢順地運作。在這種情況下,這些特別要求會列載於該等網上服務內。

  • 問11.
    我的電腦已經安裝 Java,但我仍然不能使用網上服務。而當我使用網上服務時,屏幕顯示 Java 並未啟用的錯誤訊息。為什麼會這樣和我該怎麼辦?

    當你使用網上服務時,服務系統會嘗試檢視你使用的 Java 版本,以確定該軟件能否符合使用網上服務的基本系統需求。即使你的電腦已安裝 Java,仍有其他因素可能會導致 Java 不能正常操作:

    1. 網路傳輸速度太慢。在這情況下,你可在稍後時間再嘗試使用網上服務。
    2. 安裝在你的電腦的 Java 版本太舊或你使用的瀏覽器並不支援 Java。請參閱「使用「香港政府一站通」網上服務的系統需求」網頁下載及安裝所需的版本。
    3. 你使用的瀏覽器並未啟用 Java。請參閱 (a) 設定你的瀏覽器啟用 Java。
    4. 一些留在你的電腦內的暫存檔案可能會導致 Java 不能正常運作。請參閱 (b) 清除 Java 暫存檔案。
    5. 未能正確地安裝 Java 以配合瀏覽器的使用。請注意,雖然你的電腦已安裝 Java,它仍有機會只能在其中一個瀏覽器上正常運作。請參閱 (c) 測試 Java 在你的瀏覽器上是否運作正常。如不能正常地運作,請參閱 (d) 重新安裝 Java。
    6. 若重新安裝 Java 仍未能解決你所遇到的問題,你可能要重新安裝你使用的瀏覽器。如使用 Firefox,請參閱 (e)。
    7. 一些個人防火牆軟件或瀏覽器附加元件可能會影響 Java 的使用。如 Zonealarm、 Norton Internet Security 或 NoScript、Adblock 等 Firefox 附加元件。請檢查這些軟件的設定以配合 Java 的使用。
    8. 微軟視窗8 「開始頁面模式」不支援外掛程式(包括 Java)。請轉換至微軟視窗8「桌面模式」以配合 Java 的使用。用戶可於微軟視窗8 「開始頁面模式」按「桌面」或「Windows 鍵 + D」以轉換至「桌面模式」。    
      Windows 8
      有關詳情,請瀏覽 Java 官方網站關於「在 Windows 8 上使用 Java 的疑難排解秘訣」。
    9. 微軟 Edge 瀏覽器不支援外掛程式(包括 Java)。請轉用其他瀏覽器以配合 Java 的使用。
    10. 微軟視窗上的 64 位元版 Firefox 不支援 Java 外掛程式。請轉用微軟視窗上的 32 位元版 Firefox 以配合 Java 的使用。

    說明:

    (a) 設定你的瀏覽器啟用 Java

    Internet Explorer
    (1) 在選單列上,選擇「工具」 > 「網際網絡選項」。
    (2) 選擇「安全性」的分頁並按「自訂層級」。
    (3) 將滑鼠向下移至「Java applets 的指令碼化」。
    (4) 確定「啟用」已被選擇。
    (5) 按「確定」以儲存更改。
    (6) 在選單列上,選擇「工具」 > 「管理附加元件」。
    (7) 在清單上選取「Java Plug-in {版本號碼}」。如所選取的 Java Plug-in 的狀態是「停用」,請更改為「啟用」。
    (8) 重新啟動 Internet Explorer。

    Mozilla Firefox
    (1) 在選單列上,選擇「工具」>「附加元件」。
    (2) 按「外掛程式」分類。
    (3) 請檢查「Java(TM) Platform SE {x} U {xx}」是否已啟用。若該項目已停用,請按「啟用」。因為 Firefox 會自動停用有保安漏洞的 Java 版本,你若遇到這個情況,你必須安裝最新的 Java 版本。

     

    (b) 清除 Java 暫存檔案

    關閉所有瀏覽器並檢查 Java 是否仍然在運行中。如 Java 圖像(如下圖)仍然顯示於系統工作匣中,請重新啟動你的電腦以確定 Java 沒有在電腦中運行。

    請依照以下步驟清除儲存在你電腦中的 Java 暫存檔案。

    如使用微軟視窗
    (1) 開啟視窗的控制台。
    (2) 雙擊 Java 圖像開啟「Java 控制面板」。
    (3) 選擇「一般」的分頁並在下方的「暫存網際網絡檔案」按「設定」。
    (4) 按「刪除檔案」後並按「確定」刪除所有暫存檔案。
    (5) 在「暫存檔案設定」的視窗上按「確定」。

    如使用 Mac OS X*
    (1) 在系統「HD」> 「應用程式」> 「工具程式」中開啟 Java 檔案夾。
    (2) 開啟「Java 偏好設定」程式。
    (3) 選擇「一般」的分頁。
    (4) 在分頁下方的「暫存網際網絡檔案」按「刪除檔案」後並按「確定」刪除所有暫存檔案。

    * 在不同版本中的對話方塊及欄位名稱與上面所提及的會略有出入。

    如使用 Linux
    (1) 啟動「Java Plug-In 控制面板」的執行檔:
    「(Java 安裝目錄)/bin/ControlPanel」或
    使用瀏覽噐開啟「控制面板」 applet 的網頁:
    「(Java 安裝目錄)/ControlPanel.html」。
    (2) 選擇「一般」的分頁。
    (3) 在分頁下方的「暫存網際網絡檔案」按「刪除檔案」後並按「確定」刪除所有暫存檔案。

     

    (c) 測試 Java 在你的瀏覽器上是否運作正常

    請按以下的連結測試你的 Java 版本:
    測試 Java 版本

    如 Java 運作正常,網頁會顯示一段動畫及你的 Java 版本。否則,你會看到「Java Runtime environment is not working on your system」的訊息。

     

    (d) 重新安裝 Java

    請參閱「使用「香港政府一站通」網上服務的系統需求」檢查所需要的 Java 版本及於相關的連結下載有關的軟件。關閉所有瀏覽器並執行以下的步驟:

    如使用微軟視窗
    (1) 開啟視窗的控制台。
    (2) 雙按「新增或移除程式」。
    (3) 選擇 Java 軟件並按「移除 Remove」。如有多個版本的 Java 軟件安裝在你的電腦中,請重複這步驟逐一把它們移除。
    (4) 重新啟動你的電腦。
    (5) 重新安裝 Java(建議使用最新版本的 Java 8)。

    如使用 Mac OS X
    請瀏覽 http://java.com/zh_TW/download/manual.jsp#mac 參考有關的安裝指示。

    如使用 Linux
    請瀏覽 http://java.com/zh_TW/download/manual.jsp#lin 參考有關的安裝指示。

     

    (e) 重新安裝 Firefox 瀏覽器

    倘若完成上述所有程序包括重新安裝 Java 後問題仍然存在,你可能需要重新安裝 Firefox 瀏覽器。如使用微軟視窗,重新安裝 Firefox 能修復在微軟視窗上使用 Java 的登錄機碼。

    在某些罕見的情况下,舊版本的 Java 外掛程式可能會與新版本的 Java 在 Firefox 的安裝目錄裡互相抵觸。在這情況下,你必需完整地重新安裝 Firefox。有關安裝指示可參閱下面的網頁:
    重新安裝 Firefox

    有關更多 Firefox 與 Java 的問題,請參閱以下網頁:
    使用 Java 外掛程式檢視網站上的互動內容

  • 問12.
    當我用 Internet Explorer 瀏覽器使用網上服務時,看到一個通知欄說 : 「Java 已過時和已被封鎖」。為什麼會出現這種情況?我該怎麼辦?

    根據微軟的 Internet Explorer 安全更新指引,當你使用網上服務時,Internet Explorer 會嘗試確定你的電腦是否正在採用 Java 的最新版本,以確保用戶的安全性能有效地提高。

    微軟為提供更安全的瀏覽器予用戶使用,Internet Explorer 會封鎖已過時的 Java 版本在其上運行。當 Internet Explorer 封鎖了已過時的 Java 版本,你將會看到以下的屏幕通知欄:

    IE notification bar

    (a) 要取得 Java 的更新版本:

    (1) 從通知欄,點擊「Update」。
    IE notification bar update
    (2) Internet Explorer 會打開 Oracle 的 Java 網站。
    (3) 下載最新 Java 版本。

    欲知更多詳情,請參閱微軟的官方網站,有關「How do I fix an outdated Active-X control or app?」.

    (b) 然而,如果你信任此即將瀏覽的網站,你可選擇忽略此通知欄,容許此受信任的網站在你的瀏覽器上運行已過時的 Java 版本:

    (1) 從通知欄,點擊「Run this time」。
    IE notification bar run this time
    (2) Internet Explorer 瀏覽器會進一步提供一個安全警告。在對話框中,點擊「Allow」,執行已過時的 Java 版本。
    IE notification bar allow
    (3) 否則,點擊「Don't allow」終止電腦使用已過時的 Java 版本。
    IE notification bar don't allow

    有關詳情,請瀏覽 Internet Explorer 官方網站,有關「Internet Explorer begins blocking out-of-date ActiveX controls」.

覆檢日期:2016年6月