FAQs about eTAX Technical Problems

  • Q1.
    What are the system requirements for using eTAX?
    Ans

    You should be able to access eTAX services provided on GovHK by using popular operating systems (OS) and browsers on the market.   To ensure smooth operations of the eTAX system and high security of the transactions, you are recommended to use one of the combinations of OS and browsers as listed in the System Requirements for GovHK Online Services webpage that have been fully tested for compatibility with eTAX.

    Installation of Java plug-in - Java Runtime Environment (JRE) is not necessary except for:-

    (a) * eTAX users selecting to use digital certificate for authentication or signing; and
    (b)    using older web browsers (e.g. Internet Explorer version 10 or below, Chrome version 44 or below, Firefox version 51 or below, Safari version 9 or below) to access the service of e-filing of employer's return by uploading IR56B data records.

    * [Please note that: Safari (starting from version 12), Firefox (starting from version 52) and Chrome (starting from version 45) do not support Java plug-in. If you choose to use one of these browsers and a digital certificate to access eTAX online services, you may encounter Java plug-in problem. In light of this, the Department will enhance the eTAX system by the end of 2019. After the enhancement is completed, users who use a digital certificate to log in eTAX will not encounter that problem again.]

  • Q2.
    When I try to login, why does the system always direct me back to the Landing Page?
    Ans

    Please check the settings of your browser to ensure Cookies have been enabled.

  • Q3.
    Why do I encounter error when clicking the "Refresh", "Back" button or other hot keys of the browser?
    Ans

    Under normal operation, the buttons, address bar and the hot keys of the browser are disabled by eTAX. However, by some external means, these buttons, address bar and hot keys may be enabled again. Anyhow, you should never use these buttons, address bar and hot keys, as this will affect the normal flow of the application.

  • Q5.
    Why can't some Chinese characters be displayed, even though I have installed the HKSCS on Mac OS?
    Ans

    It is known that the HKSCS from Apple does not support the full set of Chinese HKSCS characters.  You may consult Apple for more details.

  • Q6.
    Why can't some Chinese characters be displayed when I reopen a page that was saved on my hard disk?
    Ans

    There are 2 possibilities leading to this situation: 

    • When saving a page, “Unicode” or “Unicode (UTF-8)” must be chosen as the encoding scheme (Not applicable for Firefox) and HTML format should be selected in order to save the Chinese characters properly.
    • There are some HKSCS characters that are out of the standard character set.  In this connection, eTAX will display these characters as image files.  However, there are some technical problems in saving these image files via a browser. In such case, you may consider printing the page instead of saving it.
  • Q7.
    Why can’t I install the HKSCS downloaded from Digital 21 website on my Linux computer?
    Ans

    It is known that some Linux distributions will encounter problem in installing the HKSCS modules.  You may consult your dealer to see if there is any alternative.

  • Q8.
    Why is the number of Chinese characters that can be inputted in some fields less than expected?
    Ans

    Under the character-encoding standard adopted by the Operating Systems, some Chinese characters may occupy 4 bytes instead of 2 bytes.  When these Chinese characters are inputted, some browsers will interpret a 4-byte character as two 2-byte characters. Hence, the number of characters that can be inputted is less than expected.

  • Q9.
    How should I print the e-notice (in PDF format)?
    Ans

    To help protect our environment, please consider retaining the relevant information by saving the e-notice.  If printing is really necessary, you should select "Fit to Printer Margins" for "Page Scaling" under the "Page Handling" of Adobe Reader’s "Print" dialogue box so that the document can be printed in full.  The "Fit to Printer Margins" option, once selected, will remain the default option until further change.

  • Q10.
    Why can’t I log into eTAX using e-Cert when I use Linux with JRE 1.4.2?
    Ans

    Under Linux with JRE 1.4.2 environment, you are required to download the root and intermediate CA certificate from Hong Kong Post and import them to the JRE environment. You may also consider upgrading the JRE to 5.0 or later.

  • Q11.
    I encountered the following problems when running FireFox under Linux: The content could not be fully displayed or printed even though the screen size has been set to 1024 x 768. A thick underline appeared in some texts.
    Ans

    It is known that such a display problem may occur with Firefox on Linux. Please consider using other platform.

  • Q12.
    What is the required system setup in order to use Smart ID card?
    Ans

    You need to download the Smart Card Manager from Hong Kong Post and have it installed on your workstation before you can use your Smart ID card.  Besides, you need to install the proper driver for your card reader.  In many cases, you need to restart your workstation. 

    Under Windows Vista, the Hong Kong Post Smart Card Manager requires administrative right to run.  Until Hong Kong Post announces their support on Windows Vista, please use the administrator account or ask your administrator to grant you the administrative rights. 

  • Q13.
    Why do I sometimes get a blank page or a "Error 500" message?
    Ans

    This might happen occasionally when the Internet traffic is too busy. Please try again. If this happens frequently, please consider waiting for an hour or two before retrying.

    You may also encounter "Error 500" message if you access eTAX via bookmark stored in the browser . Please access eTAX from the link: http://www.gov.hk/etax

  • Q15.
    Why do I get the following errors when I open PDF documents of eTAX such as an Electronic Extract of Information on the Business Register: “Bad Encrypt Dictionary” and “Cannot extract the embedded font"?
    Ans

    Some old versions of the Adobe Reader could not manipulate the PDF documents provided on eTAX, such as the Electronic Extract of Information on the Business Register.

    Please download and install the Adobe Reader version 7.0.9 or later from Adobe website according to your Windows / OS setup. The minimum system requirement for Adobe Reader 7.0.9 is Microsoft Windows 2000 Service Pack 2.

    Adobe website

  • Q16.
    Why can’t I retrieve the Stamp Certificates?
    Ans

    Please ensure you have allowed popup windows from “*.ird.gov.hk”.

  • Q17.
    When I try to view a PDF document under eTAX, nothing is shown except a blank window pops up.
    Ans

    (For e-filing of Employer's Return service, please click here for information.)

    A PDF document may not be displayed within a compatible web browser if the web browser is not configured correctly with the Adobe PDF browser plug-in. Please try one, more or all of the following to troubleshoot and resolve the issue.

    • Reset Internet Explorer (for IE 7 or above)
      1. Open Internet Explorer.
      2. Click "Tools" and then select "Internet Options".

      1. Click the "Advanced tab". Click "Reset" under "Reset Internet Explorer" option.
      2. Click "Reset" again to confirm.

    5. Close all IE browsers and then start IE again. 

    • Save the document in Firefox
      1.  Open Firefox.

     

    1. Select "Tools" and then select "Options".
    2. Select "Applications". Find "Adobe Acrobat Document" and change the action to "Save File".

    1. Close all Firefox browsers and then start Firefox again.
    • Deselect and then reselect the Display PDF in browser preference.
      1. In Adobe Reader, choose Edit > Preferences.
      2. Select Internet.
      3. Deselect Display PDF in browser, and then click OK.
      4. Choose again the Edit > Preferences > Internet, select Display PDF in browser, and then click OK.

    • Delete temporary Internet files.

    If you use Internet Explorer, delete the temporary files that Internet Explorer creates:

    1. In Internet Explorer, select Tools > Internet Options.
    2. Click Delete Files in the General tab, and then click OK when prompted.

    If you use Firefox, delete the temporary files that Firefox creates:

    1. In Firefox, select Tool > Options.
    2. Select Privacy > Private Data > Clear Now.
    3. Tick “Cache” > Clean privacy Data now.

     

    • Install the latest version of Adobe Reader.

    Download and install the latest version of Adobe Reader from http://www.adobe.com. 

    • More...

    If you still cannot solve your problem, you may try the suggestions from the Knowledge Base of Adobe at the link below:

    http://www.adobe.com

    However, some suggestions require a skilled technical person to do it.

  • Q18.
    Why an error message of “Java Virtual Machine (JVM) Unknown” is displayed when I try to log into eTAX by e-Cert using Mac OS X platform. How can I enable the Java plug-in on my computer?
    Ans

    Mac OS X 10.10 and above
    Mac OS X 10.7 to 10.9
    Mac OS X 10.6 and below

    [Please note that: Safari (starting from version 12), Firefox (starting from version 52) and Chrome (starting from version 45) do not support Java plug-in. If you choose to use one of these browsers and a digital certificate to access eTAX online services, you may encounter Java plug-in problem. In light of this, the Department will enhance the eTAX system by the end of 2019. After the enhancement is completed, users who use a digital certificate to log in eTAX will not encounter that problem again.]


    Mac OS X 10.10 and above

    Java plug-in is disabled by default in Mac OS X 10.10 and above. Please follow the procedures to enable Java plug-in under Safari (version 11 or below):

    Step 1:

    Access eTAX service from the link of http://www.gov.hk/etax.

    Step 2: Choose Safari “Preferences…”.
     


     

    Step 3:

    Choose the “Websites” option and ensure Java plug-in has been allowed by checking (√) the “Java” option. Confirm that all “etaxXX.ird.gov.hk ” have been allowed to use Java plug-in by turning corresponding websites setting to “On”. 
     

     


    Mac OS X 10.7 to 10.9

    Mac OS X Software Update in these versions has disabled the Java plug-in under Safari. Please try the following procedures to enable Java plug-in.

    Step 1: Uninstall the Java plugin. (https://www.java.com/en/download/help/mac_uninstall_java.xml)
      
    Step 2: Reset all website notification warnings. (https://support.apple.com/en-us/HT204098)
      
    Step 3: Reinstall Java. Please noted that Oracle Java (version 7 and later version) requires an Intel-based Mac OS X 10.7.3 or later version.(http://www.java.com/en/download/manual.jsp#mac)
      
    Step 4: Restart Safari. Test if Java plug-in is working properly in the browser by visiting Oracle’s Java test site (http://www.java.com/en/download/testjava.jsp).
      
    Step 5: After activating Java plug-in, reboot your computer and log in eTAX online services.
      
    Step 6: At the loading screen, please click “Inactive Plug-in” to proceed.
      
     

     


    Mac OS X 10.6 and below

    The Java update (Mac OS X 2012-003) released by Apple on 12 April 2012 for Mac OS X 10.6 or below would disable Java plug-in by default. Please follow the procedures below to enable Java plug-in:
      

    Step 1: Select “Software Update…”.


     
    Step 2: After completion, reboot the computer and login eTAX online services.
     
    Step 3: At the loading screen, click “Inactive Plug-in” to proceed.
      
     

     

  • Q19.
    I am using Microsoft Windows PC but an error message of “Java Virtual Machine (JVM) not enabled or unknown” is displayed when I try to log into eTAX by e-Cert. How can I enable the Java plug-in on my computer?
    Ans

    Please try the following procedures to enable the Java plug-in.

    Step 1: Re-installation of Java

    Step 2: If Java problem persists after re-installation of Java, reset and enable the Java plug-in in the web browsers

    [Please note that: Safari (starting from version 12), Firefox (starting from version 52) and Chrome (starting from version 45) do not support Java plug-in. If you choose to use one of these browsers and a digital certificate to access eTAX online services, you may encounter Java plug-in problem. In light of this, the Department will enhance the eTAX system by the end of 2019. After the enhancement is completed, users who use a digital certificate to log in eTAX will not encounter that problem again.]


    Step 1: Re-installation of Java

    Step 1.1  Uninstall Java [“Java x Update xx” or “Java x Update xx (32-bit)”](https:/www.java.com/en/download/help/uninstall_java.xml).
    Step 1.2 Download the latest version of Java via https://www.java.com/en/.
    Step 1.3 After installing Java, restart the computer.
    Step 1.4 Click “Programs” in “Control Panel” and then open “Java Control Panel” by clicking “Java” or “Java (32-bit)”.
     

    Step 1.5

    Click “Settings…” under “General” tab, and then click “Delete Files…”.  Check (√) all three boxes and then press “OK”.
     

    Step 1.6

    Click “Edit Site List…” under “Security” tab and then add the following links to “Exception Site List”

    1. https://etax13.ird.gov.hk
    2. https://etax14.ird.gov.hk
    3. https://etax23.ird.gov.hk
    4. https://etax24.ird.gov.hk

     

    Step 1.7

    Click “Restore Security Prompts” and “Restore All”.
     

    Step 2:    If Java problem persists after re-installation of Java, reset and enable the Java plug-in in the web browsers

    2.1   Internet Explorer
    2.2   Firefox
    2.3   Google Chrome
     


    2.1    Reset and enable the Java plug-in under Internet Explorer

    Step 2.1.1    Select “Tools” under Internet Explorer and click “Internet options”.

    Step 2.1.2 In the tab of “Advance”, reset all Internet Explorer settings.
     

     

    Step 2.1.3 After restarting Internet Explorer, select “Tools” and click “Manage add-ons”.
     
     
     
    Step 2.1.4 Select “Java(tm) Plug-In SSV Helper” and “Java(tm) Plug-In 2 SSV Helper” and make sure they are enabled. If there is no such plug-ins, please change the drop down list of Show to “All add-ons” and enable both add-ons.
     
     
    Step 2.1.5

    Restart Internet Explorer and login eTAX again.


    2.2:  Reset and enable the Java plug-in under Firefox

    Step 2.2.1 Under “Tools”, click “Add-ons”
     

     
    Step 2.2.2 Find “Java (TM)” under “Plugins” and then click “Enable”
     

     
    Step 2.2.3 Restart Firefox and login eTAX again.
     

    2.3 Reset and enable the Java plug-in under Google Chrome
     

    Step 2.3.1 Type “chrome://plugins” in the address bar.
     

     
    Step 2.3.2 Search “Java(TM)” and then click “Enable”.
     
     
     
    Step 2.3.3 After enabling Java plug-in, please check “Always allowed” and restart Google Chrome.
     
     
  • Q20.
    Why the “Browse” button cannot be clicked when I attempted to log in eTAX via eCert in Mac OS X system?
    Ans

    Please try the following procedures to disable local file restrictions:

    Step 1: Confirm if there is a “Develop” Menu on the tool bar. If not, select “Preferences…” under “Safari”. Check (√) “Show Develop menu in menu bar” under the “Advance” tab.

     

    Step 2: Select “Disable Local File Restrictions” under “Develop” menu.
     

     
    Step 3: Restart Safari and login eTAX again.
  • Q21.
    Why can't I log into eTAX by e-Cert using Internet Explorer under the "Start Screen" mode of Windows 8 and an error message "Java Virtual Machine (JVM) Unknown" is shown?
    Ans

    We understand that Internet Explorer of Windows 8 does not support any plug-in, including Java, under the "Start Screen" mode.  To access eTAX under Windows 8, please use web browsers (such as Internet Explorer, Google Chrome or Firefox) under the "Desktop" mode.  The "Start Screen" mode under Windows 8 can be switched to "Desktop" mode by clicking "Desktop" tile (usually at the left-lower corner) or pressing "Windows logo key + D".

    The Department will enhance the eTAX system by the end of 2019. After the enhancement is completed, users who use a digital certificate to log in eTAX will not encounter the Java plug-in problem again.

  • Q22.
    I have Java Runtime Environment (JRE) installed. Why is an error message of "Java Virtual Machine (JVM) unknown" still displayed when I try to log into eTAX by e-Cert using Firefox browser?
    Ans

    Under certain circumstances, Firefox will halt and ask for the permission of running the Java Applet. If such a case happens, please try the following steps to allow the execution of Java applet.

    Step 1:

    Click the "Allow" button.

     

    Step 2 :

    Click the "Allow and Remember" button in the newly prompted dialogue. Close the Firefox browser and then restart again.

    If the above dialogue boxes do not pop up for some reasons, just directly click the icon (as shown below) in order to display the "Allow and Remember" button.

  • Q23.
    When I try to view a PDF document under eTAX, why can't the document colours be displayed properly?
    Ans

    We understand that the new version of Firefox web browser has introduced a new built-in PDF viewer by default.  Document colours may not be properly displayed if the PDF document is viewed by this browser built-in PDF viewer.  Please try the following options to troubleshoot and resolve the issue.

    Option 1: Use Adobe Acrobat Reader to view the PDF document in Firefox web browser

    Open Firefox and select "Options".

    Select "Applications".  Find "Adobe Acrobat Document (PDF)" and change the action to "Use Adobe Acrobat (in Firefox)".

    Close Firefox and start Firefox again.

    Option 2: Save the PDF document in Firefox

    Open Firefox and select "Options".

    Select "Applications".  Find "Adobe Acrobat Document (PDF)" and change the action to "Save File".

    Close Firefox and start Firefox again.

     

  • Q24.
    Why is some information of a PDF document under eTAX missing when I open it by a PDF reader?
    Ans

    Some PDF reader software (or a particular version) cannot display some information (for example, Chinese punctuation marks) of a PDF document under eTAX properly. You can try to view the PDF document under eTAX by other PDF reader software (or other versions of the PDF reader software).  You can also request for a paper copy of the document from the Inland Revenue Department if necessary.

     

  • Q25.
    Why do I get an “Error 800” message?
    Ans

    Since the system does not allow users to log into the eTAX service by opening a new window under the same browser at the same time, you will encounter “Error 800” message under the following circumstances:

    1. there is another active eTAX service session in a window under the same browser at the same time; or
    2. there is previous eTAX service session in a window under the same browser that has not been properly logged out.

    Please return to the first window to continue using the eTAX service.

    If you want to log in as another user, please log out the previous eTAX services / sessions or close all the windows under the same browser and try again.

     

  • Q26.
    I am using an operating system/browser which supports only Transport Layer Security (TLS) version 1.0 and version 1.1. Can I use eTAX services involving online payment with that operating system/browser? If not, how can I do?
    Ans

    To enhance network transmission security for online payment, effective from 24 May 2018, you must use an operating system/browser with TLS version 1.2 or above enabled when making use of eTAX services involving online payment. You need to upgrade your browser or use another browser such as Internet Explorer 10 or 11, Firefox version 27 or above, Google Chrome version 30 or above, Safari version 7 or above.

  • Q27.
    I am using an operating system/browser which supports only Transport Layer Security (TLS) version 1.0 and version 1.1. Can I use eTAX online services not involving online payment with that operating system/browser? If not, how can I do?
    Ans

    The Department is committed to complying with strict information security standards to ensure high level of security in using eTAX online services by eTAX users. With effect from 31 January 2019, we only allow operating system/browser with TLS version 1.2 or above enabled to access eTAX online services because operating systems/browsers adopting old TLS versions may have security risks. Therefore, if your browser only supports TLS versions 1.0 and 1.1, your browser will display the following error page (see Figure 1 to Figure 3) when you try to access eTAX online services.

    In order to ensure high level of security and smooth operations in using the eTAX online services, we recommend you using the tested combinations of operating system and browser as listed in the System Requirements for GovHK Online Services webpage to access eTAX online services and enabling TLS version 1.2 in your browser.  The browsers which support TLS 1.2 include Microsoft Edge, Internet Explorer 10 and 11, Firefox version 27 and above, Google Chrome version 30 and above and Safari version 7 and above.

    Figure 1: Error page under Internet Explorer 11

    Figure 2: Error page under Firefox

    Figure 3: Error page under Safari

     

  • Q28.
    How can I enable Transport Layer Security (TLS) version 1.2 in my browser?
    Ans

    Since old TLS versions may have security risks, effective from 31 January 2019, we only allow operating system/browser with TLS version 1.2 or above enabled to access eTAX online services. 

    Please follow the following steps to enable TLS version 1.2:

    Microsoft Edge

    Internet Explorer

    Firefox

    Google Chrome


    Microsoft Edge

    1. Right click “Start” button and Select “Control Panel”.

    2. Select “Network and Internet”.

    3. Select “Internet Options”.

    4.Under the tab “Advanced”, check (√) “Use TLS 1.2” and press “OK”.

    5. Close the browser. Then restart the browser again and login eTAX online services.


    Internet Explorer

    1. Select "Tools" > "Internet Options" under Internet Explorer.


     

    2. Choose "Advanced" tab. Then check the option "Use TLS 1.2" and click "OK" button.


     

    3.Close the browser. Then restart the browser again and login eTAX online services.


    Firefox

    For Firefox version 60 or above, the TLS version 1.2 of browser is automatically enabled.

    For Firefox version from 27 to 59,

    1. Type the command "about:config" in the address bar under Firefox.

    2. Type "TLS" and search. Then amend the value to “3” under “Security.tls.version.max”.

    3. Close the browser. Then restart the browser again and login eTAX services.


    Google Chrome

    For Google Chrome version 66 or above, the TLS version 1.2 of browser is automatically enabled.

    For Google Chrome version from 30 to 65,

    1. Type the command "chrome://flags/#ssl-version-max" in the address bar under Chrome.
    2. Select "TLS 1.2" from the drop-down box.
    3. Click “RELAUNCH NOW” to start the browser.

    4. Close the browser. Then restart the browser again and login eTAX online services.

     

  • Q29.
    I have tried different browsers such as Internet Explorer version 11 or above, Firefox version 55 or above, Google Chrome version 61 or above, why eTAX messages are still popped up that the browsers do not meet the requirement of using enabled TLS version 1.2?
    Ans

    Although you have used modern browsers, you have not yet enabled TLS version 1.2. Please refer to the answer in Q28 to enable TLS version 1.2.

Last revision date: July 2019
Found this page helpful?
Your feedback is highly appreciated.(optional)
Notice: This form is NOT intended for handling enquiries or complaints. For assistance, please contact the 24-hour Helpdesk at (852) 183 5500 or email to enquiry@1835500.gov.hk .
Thank you. Your input will only be  used to improve GovHK.
Thank you for your valuable feedback!

Thank you for using "XXXX".
Base on today’s experience, please rate the online service on all aspects below:

  1. 1.  Easiness of use
  2. 2.  Clarity of instructions
  3. 3.  Overall satisfaction