System Requirements for GovHK Online Services

System Requirements for GovHK Online Services

When starting a GovHK online service, system configuration of your device (e.g. operating system and browser), will be checked to ensure that your device is capable of running the online service properly.

Unless otherwise stated in the individual online services, online services in this website can generally be run in the following combinations of popular operating systems and browsers:

  Microsoft Windows 7Microsoft Windows 8Microsoft Windows 10Mac OS XLinux
Microsoft Internet Explorer Yes Yes Yes Not
applicable
Not
applicable
Microsoft Edge  Not
applicable
Not
applicable
Yes Not
applicable
Not
applicable
Safari Not
applicable
Not
applicable
Not
applicable
Yes Not
applicable
Mozilla Firefox
Yes Yes Yes Yes Yes
Google Chrome  Yes Yes Yes Yes Yes

Some GovHK Online Services support Digital Certificate. If you choose to use Digital Certificate, you are required to use Internet Explorer or Safari to access the online services, and have Java Runtime Environment (JRE) installed.

If you use the e-Cert on your Smart ID card, you also need:

Note:

1: For security and performance reasons, Microsoft only supports the most current version of Internet Explorer available for a supported operating system. We recommend users access GovHK online services through the latest version of Internet Explorer for their respective Windows operating system. More details are available from the official website of Microsoft.

2: Microsoft Edge does not support Java plug-in. If you choose to use a digital certificate to access GovHK online services through Microsoft Edge, you may encounter Java plug-in problems.

3: Firefox has ceased to support Java plug-in starting from version 52. If you choose to use a digital certificate to access GovHK online services through Firefox, you may encounter Java plug-in problems.

4: Google releases updates of Chrome automatically, and GovHK online services with the latest version of the browser will be tested. As it takes time to perform testing, if you experience any issues in using GovHK online services with Chrome, please report it to our Help Desk.

5: For security and performance reasons, Google has made changes to Chrome, which has ceased to support Java plug-in. If you choose to use a digital certificate to access GovHK online services through Chrome, you may encounter Java plug-in problems. More details are available from the official website of Java.

Browser Configuration

In general, to use GovHK online services, you need to enable the following in your browser:

  • Javascript
  • Cookies
  • TLS
  • Java 8

New Operating Systems and Browsers

When a new operating system or browser is released to the public, relevant Government bodies need to conduct compatibility tests to ensure proper function of the online services on the new operating system or browser. When compatibility issues arise, modification on the online service may be required. The whole process of modification and testing may take a few months to complete.

Downloading Java

You can download Java from the following links.

Please call the GovHK Help Desk at 183 5500 in case you need assistance in downloading Java.

Enquiries

If you encounter problems in using a GovHK online service, please report them to the GovHK Help Desk (telephone: (852) 183 5500 or email: enquiry@1835500.gov.hk) together with the exact version of the operating system and browser you are using.

Make enquiry via e-form/en/apps/1823enquiry.htm

Last revision date: July 2018
Found this page helpful?
Your feedback is highly appreciated.
Notice: This form is NOT intended for handling enquiries or complaints. For assistance, please contact the 24-hour Helpdesk at (852) 183 5500 or email to enquiry@1835500.gov.hk .
Thank you. Your input will only be  used to improve GovHK.